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PROPRIETARY NOTICE AND DISCLAIMER 

Unless noted otherwise, this document and the information herein disclosed are proprietary to MCCI 

Corporation, 3520 Krums Corners Road, Ithaca, New York  14850 (“MCCI”).  Any person or entity to 

whom this document is furnished or having possession thereof, by acceptance, assumes custody thereof 

and agrees that the document is given in confidence and will not be copied or reproduced in whole or in 

part, nor used or revealed to any person in any manner except to meet the purposes for which it was 

delivered.  Additional rights and obligations regarding this document and its contents may be defined by 

a separate written agreement with MCCI, and if so, such separate written agreement shall be controlling. 

The information in this document is subject to change without notice, and should not be construed as a 

commitment by MCCI.  Although MCCI will make every effort to inform users of substantive errors, MCCI 

disclaims all liability for any loss or damage resulting from the use of this manual or any software 

described herein, including without limitation contingent, special, or incidental liability. 

MCCI, TrueCard, TrueTask, MCCI Catena, and MCCI USB DataPump are registered trademarks of MCCI 

Corporation. 

MCCI Instant RS-232, MCCI Wombat and InstallRight Pro are trademarks of MCCI Corporation. 

All other trademarks and registered trademarks are owned by the respective holders of the trademarks 

or registered trademarks. 
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1 Introduction 

 The MCCI Catena® 4610 is a complete single-board IoT device for LoRaWAN™ technology 

projects. 

Based on the Murata CMWX1ZZABZ-078, and designed to be compatible with the Adafruit 

Feather family of development boards and accessories, the Catena 4610 is a great platform for 

LoRaWAN investigation and deployment. It works well with The Things Network, or any 

LoRaWAN 1.0 or 1.1 network in the 865 to 923 MHz range. 

Lightweight and small (roughly 2" by 0.9"), the 4610 needs no external components to measure 

and send temperature, pressure, humidity, and lux, powered from USB or any Feather-

compatible LiPo (Lithium-Polymer) battery. 

Because of the embedded FRAM, the Catena 4610 fully meets the requirements of LoRaWAN 

1.1, without worrying about EEPROM wearout or wear-leveling, both for ABP and OTAA. 

Figure 1 Catena 4610 

 

2 Specifications and Features 

The specifications and features of Catena 4610 is given below: 

Murata LoRaWAN module 

 Semtech SX1276 LoRa radio 

 STM32L082 CPU (Cortex M0+, 32 MHz, 192K flash, 20K RAM) 

http://wireless.murata.com/eng/products/rf-modules-1/lpwa.html
https://www.adafruit.com/feather
https://www.adafruit.com/feather
https://thethingsnetwork.org/
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 High quality RF engineering 

 Certified for US and EU 

 Compatible with IN866, AS923, AU921 bands 

Figure 2 Catena 4610 Description 

 

Integrated sensors 

 Pressure 

 Temperature 

 Humidity 

 Light 

2.1 Additional Features 

 Powered from secondary 4V LiPo batteries (such as Adafruit's 350 mAh battery) (Note: in 

contrast to the Catena 4612, this model targets LiPo batteries only. If you need 

primary/disposable batteries, please consider the 4612). 

 100uA current draw in stand by 

 8K bytes FRAM for LoRaWAN provisioning info and frame counters -- power can be removed 

completely without requiring a new join to the network, and without losing uplink and downlink 

count values (required for LoRaWAN 1.1) 

 1M byte SPI Flash for bulk data storage, future FoTA firmware storage, etc. 

 Software-controlled boost converter allows dynamically raising voltage to 3.3V for analog 

measurement and powering internal sensors 

 USB or SWD for download and debug 

 Pin-compatible with Adafruit Feather M0 family of boards (some limitations because the of 

functional differences between the Murata module and the Atmel SAMD21 CPU used in the 

Feather M0) 

 Arduino-compatible 
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 Compatible with the MCCI Catena 4450 and Catena 4612IoT devices 

 Designed for use with The Things Network (open-source, user-owned IoT network based on 

LoRaWAN); but can be used with any LoRaWAN-compatible network 

 Provisions for screw terminals for pulse, analog or digital I/O 

 Software-controlled switches for external power output to screw terminals 

 Whip, u.FL, or SMA antenna 

 Open source hardware and software (https://github.com/mcci-catena) 

 MCCI provides a full Arduino board-support package, available here. 

 MCCI also provides libraries to allow rapid prototyping and experimenting, including an open-

source LoRaWAN stack that supports the EU868, US915, AS923, AU921 and IN866 regional plans. 

 ST Micro tools may also be used. 

 The Catena 4610 works well with and is tested with The Things Network (an open-source, user-

owned IoT network based on LoRaWAN); but can be used with any LoRaWAN-compatible 

network. 

3 Catena 4610 Pinouts 

Catena 4610 Pinout is given below: 

Figure 3 Catena 4610 Pinout 
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4 Hardware Requirements 

4.1 PinHeaders 

12-pin & 16-pin male headers (123001009 & 12301011) have a pitch of 0.1” (2.54mm).  

Figure 4 12-pin & 16-pin Male Headers 

 

4.2 1x04 Screw Terminals 

The 1x4 screw terminal blocks (123001012) has a pitch of 0.1” (2.54mm), and can be used as an 

alternative to standard male or female headers of 0.1”. They help in connecting external sensors to the 

4610. 
Figure 5 1x04 Screw Terminals 

 

4.3 Antenna 

Whip Antenna, u.FL and SMA Antennas can be used. The antenna specifications are shown in Table 1 

Figure 6 Whip Antenna 

 

Table 1 Antenna Specification 

Parameters Reference US Version EU Version IN Version  AU Version AS Version 
Wire Color  Yellow Green Blue Yellow Yellow 

Reference Number  123001007 123001069 123001070 123001007 123001007 

Wire length L1 88.6 84.2 88.9 82 82 

Tolerance  - +/- 0.3 mm +/- 0.3 mm +/- 0.3 mm +/- 0.3 mm +/- 0.3 mm 

Board thickness W1 1.5748 1.5748 1.5748 1.5748 1.5748 

Tin length L2 3 mm 3 mm 3 mm 3 mm 3 mm 

Tin tolerance  - +/- 0.03 mm +/- 0.03 mm +/- 0.03 mm +/- 0.03 mm +/- 0.03 mm 

Slop from soldering L3 1.5 mm 1.5 mm 1.5 mm 1.5 mm 1.5 mm 
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Minimum length - 80.9 80.9 85.6 80.9 80.9 

Maximum length - 82.9 82.9 86.6 82.9 82.9 

Typical length L4 81.9 81.9 87.6 81.9 81.9 

Minimum f - 903.83 MHz 903.83 MHz 855.33 MHz 915 MHz 920 MHz 

Maximum f - 928.80 MHz 928.80 MHz 875.87 MHz 928 MHz 925 MHz 

Typical f - 915 MHz 915 MHz 866 MHz 921 MHz 923 MHz 

 

4.4 Programming Requirements 

4.4.1 ST-LINK/V2 in-circuit debugger/programmer 

The ST-LINK/V2 (123001120) is an in-circuit debugger and programmer for the STM8 and STM32 

microcontroller families. The single wire interface module (SWIM) and JTAG/serial wire debugging (SWD) 

interfaces are used to communicate with any STM8 or STM32 microcontroller located on an application 

board. 

Figure 7 ST Link Programmer 

 

4.4.2 USB to Serial Cable 

USB to Serial Cable (123001121) is used for Configuring the device with TTN and also for 

monitoring the device performance on the Serial Monitor. 

Figure 8 USB to Serial Cable 

 

Note: The Serial cable configurations are mentioned in the Table 2 
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5 Software Requirements 

To proceed with Catena 4610 setup and test procedure, the below software tools are required. 

 Arduino IDE for windows can be downloaded from below link: 

o https://www.arduino.cc/en/Main/Software 

 ST-Link Debugger driver for windows can be downloaded from the link below: 

o https://www.st.com/en/development-tools/st-link-v2.html 

 USB to Serial converter for windows 

 Zadig tool is required for programming Catena 4610 the tool can be downloaded from the link 

below: 

o https://zadig.akeo.ie 

 Catena-Sketches for examples of all Catena devices (catena4612_simple.ino and 

catena461x_test01.ino can be used for Catena 4610). Use command “git clone 

https://github.com/mcci-catena/Catena-Sketches.git” to clone Catena Sketches. 

 Basic libraries required 

o Catena-Arduino-Platform 
o Catena-mcciadk 
o arduino-lorawan 
o arduino-lmic  
o Adafruit_BME280_Library 
o Adafruit_FRAM_I2C 
o Adafruit_Sensor 

6 Assembly Instructions 

1) Catena 4610 board assembling procedures are listed below: 
a. Attach the 12-pin & 16-pin Male Headers on JP1 and JP2 of Catena 4610 board 

respectively. 
i. Solder one or two posts on each strip,  to tack the header in place 

ii. Adjust the vertical and horizontal alignment 
iii. Solder the remaining posts for reliable electrical contact 

b. Trim excess length of the 16-pin header in the area of screw terminals. 
c. Solder the Whip antenna as per the Antenna Specification mentioned in Table 1. 
d. Attach the 1x04 Screw Terminals  on JP3 and JP4 respectively. 

i. Solder one post 
ii. Adjust for proper alignment and good cosmetics 

iii. Solder the remaining posts 

NOTE: Catena 4610 Base do not require male pin headers and screw terminals to be soldered (only 
whip antenna is sufficient for base board). However, user can solder them based on their setup 
requirement. 

https://www.arduino.cc/en/Main/Software
https://www.st.com/en/development-tools/st-link-v2.html
https://zadig.akeo.ie/
https://github.com/mcci-catena/Catena-Sketches
https://github.com/mcci-catena/Catena-Sketches.git
https://github.com/mcci-catena/Catena-Arduino-Platform
https://github.com/mcci-catena/Catena-mcciadk
https://github.com/mcci-catena/arduino-lorawan
https://github.com/mcci-catena/arduino-lmic
https://github.com/mcci-catena/Adafruit_BME280_Library
https://github.com/mcci-catena/Adafruit_FRAM_I2C
https://github.com/mcci-catena/Adafruit_Sensor
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Figure 9 Catena 4610 after soldering components 

 

e. Connect the Battery to the X3 of the board.  

Figure 10 Catena 4610 with Battery 

 
 

(Note: The orange plastic seal from the BME–280 (U1) should be removed for proper 

operation. This seal is intended for protection during manufacturing) 

 

2) Catena 4610 Serial connection. 
User can prefer Generic Serial for Serial Interface when USB cable is not used in the setup. 

MCCI preferred using USB to Serial Cable TTL-232R-RPI and it has been used for Serial 

monitor. The color code and the pin configuration detail are listed in the Table 2 

https://www.digikey.in/product-detail/en/ftdi-future-technology-devices-international-ltd/TTL-232R-RPI/768-1204-ND/4382044?utm_adgroup=Cables&mkwid=siZUoNmAq&pcrid=275741082467&pkw=&pmt=b&pdv=c&productid=&&gclid=Cj0KCQiA1sriBRD-ARIsABYdwwF6TNQ_cRAuwTtonDhDXMLH2KG4-YfhIA-QNbjqH6KLuw2X9diCLZYaAmN_EALw_wcB
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Figure 11 Catena 4610 Serial Configuration 

 

 
 

Table 2 USB to Serial Connection 

Catena4610 (JP1) USB - Serial cable (color) 

GND Black 

D0_RX Orange 

D1_TX Yellow 

7 Configurations of Catena 4610 

7.1 Library Installation 

Catena 4610 simple sketch requires the following libraries: 

 Catena-Arduino-Platform 

 Catena-mcciadk 

 arduino-lorawan 

 arduino-lmic  

 Adafruit_BME280_Library 

 Adafruit_FRAM_I2C 

 Adafruit_Sensor 
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The above libraries can be cloned from https://github.com/mcci-catena or by executing the shell script 

“git-boot.sh” in the directory. 

It's easy to run, provided you're on Windows, macOS, or Linux, and provided you have git installed. We 

tested on Windows with git bash from https://git-scm.org, on macOS 10.11.3 with the git and bash 

shipped by Apple, and on Ubuntu 16.0.4 LTS (64-bit) with the built-in bash and git from apt-get install git. 

Refer the Figure 12 to clone using the script git-boot.sh. 

Figure 12 Cloning libraries using the script 

 

7.2 Arduino IDE Setup 

Now follow the below steps to upload the test sketch using Arduino IDE: 

1. Open the example catena4612_simple in Arduino IDE. Go to File>Preferences>Settings. Add  

“https://github.com/mcci-catena/arduino-

boards/raw/master/BoardManagerFiles/package_mcci_index.json”  

to the list in Additional Boards Manager URLs. 

https://github.com/mcci-catena
https://git-scm.org/
https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4612_simple
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2. If you already have entries in that list, use a comma (,) to separate the entry you're adding from 

the entries that are already there. 

3. Next, open the board manager. Tools>Board:...Search for MCCI’s BSPs 

4. Install the latest BSP for MCCI Catena STM32 to add support for Catena 4610 in Arduino IDE.  

5. MCCI Catena STM32 Boards should be installed from the Boards Manager. 

6. Once the board has been installed, Catena 4610 board has to be selected under MCCI Catena 

STM32 Boards. 

Figure 13 BSP Search 

 
 

Figure 14 BSP Installation 
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Figure 15 BSP Installed 

 

Figure 16 Selection of device from list of boards 
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7. Enable USB Serial/Generic Serial in the serial interface menu from the Tools tab. 

8. Choose your desired system clock and LoRaWAN region 

9. Compile and Upload your sketch 

7.3 Programming Methods 

Catena 4610 programming includes two methods 

I. ST-Link  

II. DFU 

7.3.1 ST-LinK  

Catena 4610 uses ST-Link V2 programmer for programming the firmware. Below is the connection 

between 4610 and ST-Link programmer 

Figure 17 Catena 4610 connection  with PC using STLink Debugger 

 

Pin configurations  of the ST-Link debugger with Catena 4610 are mentioned in Table 3 

Table 3 Catena 4610 to STLink connection 

Catena 4610 ST-Link connection 

Pin Names  
ST-Link 

Pin Numbers 

4610 

Pin Numbers 

+VDD Pin 1 JP1 - 15 

GND Pin 3 JP1 - 13 

SWDIO Pin 7 JP3 - 9 

SWCLK Pin 9 JP3 - 8 

nRST Pin 15 JP1 - 16 
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Figure 18 Catena 4610 connection with ST Link programmer 

 

Before uploading the code select the following options from Arduino IDE. 

 

TOOLS --> UPLOAD METHOD - STLink" && PROGRAMMER - "STLink (STM32L0)" 

Figure 19 Configuration for upload using STLink programmer 
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7.3.2 DFU 

1. Program the Catena 4610 using DFU mode, this mode requires Zadig tool the download link is 

mentioned above. 

2. Once the tool is downloaded, Catena 4610 have to be configured to DFU mode (STM Bootloader) 

by pressing button BOOT0 and then RESET immediately. 

Figure 20 Catena 4610 DFU Mode Connection 

 
 

 

3. On the Zadig terminal - Select Options -> List All devices as shown  

Figure 21 Zadig Device Selection 

 

4. Select STM32 BOOTLOADER from the device dropdown 

5. Select WinUSB (v6.1.7600.16385) as new driver 

6. Click Replace Driver 
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Figure 22 Zadig driver replacement 

 
 

 

7. Before uploading the code select the following options from Arduino IDE. 

 

TOOLS --> UPLOAD METHOD - DFU" && PROGRAMMER - "STM 32 BOOTLOADER" 

Figure 23 Configuration for upload using DFU mode 

 

Now the Sketch can be compiled and  uploaded using DFU mode. 
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7.4 Provisioning Steps 

After upload the sketch.  

Please follow the provisioning steps mentioned in the below link 

https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4450m101_sensor#provision-

your-catena-4450  

Note: use platformguid “53ca094b-b888-465e-aa0e-e3064ec56d21” 

7.5 TTN Registration Steps 

Please follow the steps mentioned in the below link to create an application in The Things Network 

https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4450m101_sensor#getting-

started-with-the-things-network 

 

 

https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4450m101_sensor#provision-your-catena-4450
https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4450m101_sensor#provision-your-catena-4450
https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4450m101_sensor#getting-started-with-the-things-network
https://github.com/mcci-catena/Catena-Sketches/tree/master/catena4450m101_sensor#getting-started-with-the-things-network
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